Programm lässt sich nicht mehr öffnen

Hier kann man Fragen stellen zu den Gesangbüchern - alles wenn es um Lieder und Noten geht.
Forumsregeln
Sie haben eine Frage zu einem Gesangbuch z.B. zu den Lieder oder den Umgang mit Noten? Hier rein damit!
Martha
Beiträge: 4
Registriert: 2017-12-07 21:22

Programm lässt sich nicht mehr öffnen

Beitrag von Martha » 2017-12-07 21:43

Hallo,

seit ein paar Tagen hat mein Gesangbuchprogramm (3.0) eigenartige Dinge getan. Normal kopiere ich die Notengrafik mit Strg+C und füge sie dann in InDesign ein. Seit Jahren problemlos. Nun fiel mir auf, dass die Noten in InDesign anders ankamen als ich sie erstellt hatte. Ein Versuch mit Word ergab dasselbe Problem.

Wie empfohlen, habe ich das hier versucht (s.u.), es erschien aber sofort der Fehlercode 0x80040200
Fehlermeldungen bei der internen Textverarbeitung

Probieren Sie zunächst einmal das Programm als Administrator zu öffnen.
Es sollte im Kontextmenü (Rechtsklick) ein Menüpunkt geben.

Tritt der Fehler auch im Administrator Modus auf versuchen Sie bitte folgendes:

Schließen Sie das Programm
Klicken Sie auf den Windows Start-Knopf und dann in das Suchfeld unten links
Geben Sie dort folgendes ein: regsvr32 "c:\bibel digital\tx4ole14.ocx"(WICHTIG: ersetzen Sie den Dateipfad "c:\bibel digital\" mit dem Dateipfad wo Sie Ihre EG 3.1 installiert haben.)
Klicken Sie nun auf den Eintrag, es müsste daraufhin eine Meldung erscheinen. Wenn das letzte Wort "succeeded." lautet (oder sonst eine positive Meldung erscheint) wurde der Fehler erfolgreich behoben.
Starten Sie wieder das Programm.
Ein schneller Test lässt sich mit Menü "Datei", der Punkt "Neu" durchführen. Wenn sich hier nun ein leeres Formular öffnet, funktioniert alles wieder.

Falls dann jedoch ein Fehlercode 0x80040200 auftritt:

Dieses Problem tritt gelegentlich auf, wenn das vorige Problem gelöst wurde.

Hier die Vorgehensweise für die deutsche Windows Vista und 7-Version:

Klicken Sie auf den Windows-Startknopf -> Alle Programme -> Zubehör
Rechtsklick auf DOS-Eingabeaufforderung -> Als Administrator ausführen und Abfrage bestätigen
Es öffnet sich die DOS-Eingabeaufforderung, dort muss der Befehl regsvr32 "c:\bibel digital\tx4ole14.ocx" eingegeben und mit Enter bestätigt werden. (WICHTIG: ersetzen Sie den Dateipfad "c:\bibel digital\" mit dem Dateipfad wo Sie Ihre EG 3.1 installiert haben.)
Anschließend sollte auch diese Fehlermeldung dann verschwinden



Seitdem öffnet sich das Programm gleich mit einer Fehlermeldung:
"im Programm trat eine Ausnahme auf"

Ich würde das Ganze gern deinstallieren und neu installieren, vielleicht hilft das ja - doch in der Systemsteuerung finde ich unter Programme deinstallieren nichts.

Das Weihnachten naht, und ich noch viele Gottesdienstblätter machen sollte, bin ich etwas unter Druck und für jede Anregung sehr dankbar

Viele Grüße, Martha

Martha
Beiträge: 4
Registriert: 2017-12-07 21:22

Programm lässt sich wieder öffnen, aber...

Beitrag von Martha » 2017-12-09 11:19

Hallo, da bin ich noch einmal,

inzwischen habe ich herausgefunden, dass ich den Ordner "eg" einfach von Hand löschen kann. Das habe ich getan, und neu installiert. Meine Einstellungen waren allerdings noch vorhanden - ich scheine nicht alles gelöscht zu haben. Wieder kam die Fehlermeldung "eine Ausnahme ist aufgetreten", diesmal hatte ich aber die Option, das Programm fortzusetzen. Zumindest kann ich nun wieder etwas tun.
Was bleibt ist das Phänomen, dass sich die Verteilung der Takte in der Zwischenablage ändert.
z.B. bei Lied 34
In meiner Einstellung sind immer zwei Takte auf einer Linie.
Kopiere ich das Lied und füge es in Word/InDesign ein, sind weiterhin zwei Takte auf einer Linie, nur Takt 3-6 Quetschen sich auf eine Linie.

Was kann das sein? :?

Viele Grüße, Martha

Martha
Beiträge: 4
Registriert: 2017-12-07 21:22

Re: Programm lässt sich nicht mehr öffnen

Beitrag von Martha » 2017-12-10 19:37

Hallo nochmal,

ich bin einen Schritt weiter gekommen. Das Problem liegt nicht an der Zwischenablage sondern am Programm selbst. Wenn ich die Noten mit meiner Formatierung lade und in den Modus "In interne Textverarb." gehe, werden die Noten ebenfalls falsch dargestellt.

Ich habe einen Screenshot erstellt und angehängt, wo das Problem ersichtlich wird. Zeile 1 und 3 sind mit 2 Takten korrekt, in Zeile 2 sind 4 Takte.

Wie bekomme ich MFchi dazu, in allen Zeilen jeweils nur 2 Takte anzuzeigen?
Dateianhänge
problem.png
Problem in der 2. Zeile
problem.png (182.21 KiB) 1335 mal betrachtet

Matthias Frey
Site Admin
Beiträge: 1537
Registriert: 2006-09-23 17:42

Re: Programm lässt sich nicht mehr öffnen

Beitrag von Matthias Frey » 2017-12-11 18:50

Hallo,
das letztere scheint dann wohl nur ein Bedienungsproblem zu sein. Ich vermute, dass bei dem Einstellungen bei Umbruch "Abschnitt" eingestellt ist.
Genau zwei Takte einstellen kann man nicht, aber versuchen Sie es mal mit der Einstellungen "Taktstrich".

Sie kommen dahin wenn die Noten offen sind über das Menüband "Liedbearbeitung", dort erste Schaltfläche "Darstellung ändern", dann "Umbruch"

Hilft das?

Martha
Beiträge: 4
Registriert: 2017-12-07 21:22

Rätsel gelöst

Beitrag von Martha » 2017-12-13 18:00

Hallo,

danke für die Antwort. Mit den verschiedenen Umbrüchen (Abschnitt, Takt, Noten) habe ich natürlich experimentiert, das hat aber nichts geändert.
Inzwischen habe ich aber mehr oder weniger zufällig des Rätsels Lösung gefunden. Früher hatte ich mein Layout mit der Einstellung "so breit wie angegeben" 172 mm angelegt. Da muss ich unwissentlich etwas verändert haben, denn als die Probleme begannen, standen 174 mm drin.
Jetzt habe ich wieder 172 mm und siehe da, alles funktioniert prima.

Das finde ich sehr rätselhaft, denn eigentlich müsste es doch auch anders funktionieren? Doch ich bin sehr froh, dass ich nun wieder damit arbeiten kann.

Viele Grüße, Martha

Matthias Frey
Site Admin
Beiträge: 1537
Registriert: 2006-09-23 17:42

Re: Programm lässt sich nicht mehr öffnen

Beitrag von Matthias Frey » 2017-12-15 17:16

Es freut mich, dass es nun funktioniert. Rätselhaft ist das schon. Vielen Dank für Ihre Rückmeldung.

Antworten