"Es befindet sich kein Datenträger im Laufwerk..."

Hier geht es um Fragen zur Bedienung vom MFchi (ausgenommen Gesangbücher und Installation)
Forumsregeln
Hier geht es um Fragen zur Bedienung vom MFchi (ausgenommen Gesangbücher und Installation)
xDavid
Beiträge: 5
Registriert: 2008-07-18 14:57

"Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von xDavid » 2012-12-17 11:58

Hallöle,

im Zusammenhang mit MFchi (bzw. während des Programmstartes) ist mir bis gestern regelmäßig die Fehlermeldung "Es befindet sich kein Datenträger im Laufwerk. Legen Sie einen Datenträger in Laufwerk Device\Harddiskx\DRx ein" aufgetreten, wobei "x" jeweils eine Zahl ist, z.B. 3.

Diese Fehlermeldung erschien bei jedem Start von MFchi zweimal und mußte jeweils weggeklickt werden, ehe MFchi tatsächlich starten konnte. Nicht Schlimmes also, aber auf Dauer nervig.

Das ist, wie ich vermute, kein echtes MFchi-Problem, sondern eines von Windows, das auch mit anderen Programmen auftreten kann (bei mir aber tatsächlich nur mit MFchi aufgetreten ist).

Ich weiß nicht, was diesen Fehler verursacht hat oder warum MFchi auf das betreffende Laufwerk zugreifen will (es handelt sich bei mir um den SD-Slot des per USB angeschlossenen externen Multi-Card-Readers, wobei ich diesen Slot eigentlich nie benutze, da mein Notebook einen eingebauten SD-Slot hat).

Folgende Schritte haben bei mir unter Windows 7 (x64) zur Lösung geführt:

1. Das betreffende Laufwerk ausfindig machen (DR3 z.B. taucht in "Systemsteuerung - Verwaltung - Computerverwaltung - Datenspeicher - Datenträgerverwaltung" als "Datenträger 3" auf)

2. Mit einem Rechtsklick auf das Laufwerk am o.g. Ort kann man die "Eigenschaften" aufrufen und so erkennen, um welches i.d.R. Wechsellaufwerk es sich handelt (z.B. den SD-Slot eines Card Readers: "Generic USB SD Reader USB Device")

3. In dieses Laufwerk, das wahrscheinlich leer ist, einen passenden Datenträger einführen und, nachdem Windows ihn erkannt und eingebunden hat, wieder entfernen (Hinweis: Möglicherweise ist dieser Schritt nicht erforderlich, aber das konnte ich nicht überprüfen - nach diesem Schritt jedenfalls fehlermeldet MFchi beim nächsten Start, man möge einen Datenträger in Laufwerk Y: einlegen, nennt dann also nicht mehr "Device\Harddiskx\DRx, sondern den entsprechenden Laufwerksbuchstaben)

4. Nun am o.g. Ort in der Datenträgerverwaltung mit einem Rechtsklick auf das betreffende Laufwerk "Laufwerkbuchstaben und -pfade ändern" aufrufen und den Laufwerkbuchstaben entfernen

5. Nun sollte MFchi beim nächsten Mal ohne Fehlermeldung starten - zumindest war das bei mir so (auch nach einem Neustart von Windows)

6. Legt man nun einen Datenträger ein, wird Windows erst einmal keinen Laufwerksbuchstaben vergeben. Darum habe ich in der Datenträgerverwaltung einen neuen Laufwerksbuchstaben vergeben (also nicht den vorher verwendeten, sondern z.B. den nächsten freien); dies hat keine Fehlermeldung beim Start von MFchi mehr zur Folge, egal ob ein Datenträger eingelegt ist oder nicht (Hinweis: Möglicherweise kann man auch unter Schritt 4. anstelle der Löschung des Laufwerkbuchstabens gleich einen neuen vergeben wie hier beschrieben; das habe ich aber nicht ausprobiert)

Falls also jemand das gleiche Problem beim Start von MFchi hat, hilft ihm dieser Lösungsweg hoffentlich :-)


Grüßle

Michael

Matthias Frey
Site Admin
Beiträge: 1533
Registriert: 2006-09-23 17:42

Re: "Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von Matthias Frey » 2012-12-17 22:15

Hallo,
Danke für Deine Ausführungen, ich selber hatte auch mal so ein Problem. Normalerweise sollte MFchi Wechseldatenträger in Ruhe lassen.

Helfen könnte vielleicht auch folgendes:
Matthias Frey hat geschrieben:
  • Suchen Sie die Datei "mfbo.ini". Wenn Sie die nicht finden: Wählen Sie das Menü "Einstellungen", dort den Punkt "Programmeinstellungen". Im Fenster "Programmeinstellungen" klicken Sie links fast unten "Verzeichnisse". Rechts wird dann bei "Datei für Programmeinstellungen" ein Verzeichnis angezeigt. Durch einen Klick auf das Symbol rechts daneben wird ein Windowsfenster in dem Verzeichnis geöffnet. Dort finden Sie die Datei "mfbo.ini".
  • Falls offen, schließen Sie nun das Programm.
  • Suchen Sie dort den Abschnitt "[Oem]" (vielleicht der erste)
  • Ändern oder ergänzen Sie dort eine Zeile mit Inhalt "TakeDrive=C"
  • Datei schließen, dabei speichern.
Grüßle
Matthias

xDavid
Beiträge: 5
Registriert: 2008-07-18 14:57

Re: "Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von xDavid » 2012-12-18 19:47

Hallo Matthias,

in der INI-Datei hatte ich natürlich ziemlich zuerst nach einem entsprechenden Eintrag gesucht, aber nichts gefunden. Das mit dem "TakeDrive=C" hatte ich freilich nicht ausprobiert.


Grüßle

Michael

Matthias Frey
Site Admin
Beiträge: 1533
Registriert: 2006-09-23 17:42

Re: "Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von Matthias Frey » 2012-12-18 20:40

Hallo,
das ist ein Spezialeintrag. Normalerweise ist der nicht da drin.
Matthias

Fisherman
Beiträge: 2
Registriert: 2016-10-30 15:41

Re: "Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von Fisherman » 2016-10-30 16:00

Auch wenn dieser Thread schon Jahre alt ist, habe ich doch seit kurzem exakt diese Fehlermeldung - und zwar seit Installation der Lutherbibel 2017.
Das betreffende Laufwerk ist Teil eines Kartenlesegerätes, stöpsele ich das Gerät ab, verschwindet auch die Meldung. Ein mühsamer Workaround, da ich sowohl Lesegerät als auch MFchi recht häufig nutze.

Der Eintrag "TakeDrive=C" unter [OEM] in der "mfbo.ini" hilft leider nicht weiter.

Gibt's andere Lösungen?

Matthias Frey
Site Admin
Beiträge: 1533
Registriert: 2006-09-23 17:42

Re: "Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von Matthias Frey » 2016-11-01 07:20

Hallo,
ich bin etwas ratlos. Mit der Programmversion der Lutherbibel 2017 hat sich bezüglich dieser Sache meines Wissens nichts geändert.
Es gibt im Menü Hilfe den Punkt "Supportbericht versenden", mit dem Sie mir einen Bericht senden können. Da kann ich dann vielleicht Einzelheiten erkennen, die zur Lösung beitragen. Bitte da dabei aufs Forum hier verweisen, dass ich den Bezug sehen kann.

Fisherman
Beiträge: 2
Registriert: 2016-10-30 15:41

Re: "Es befindet sich kein Datenträger im Laufwerk..."

Beitrag von Fisherman » 2016-11-02 21:45

Danke für die Rückmeldung.
Hat sich nun aber erledigt - ich habe alles noch einmal in einem neuen Verzeichnis neu installiert.
Die Fehlermeldung ist weg.

Antworten